Wednesday, May 26, 2010

she sits down to her colored thread

A friend of mine got me in touch with one of the Emerald developers today. I had what I thought was an inoperable problem with the new beta release--now, I grant you, it says 'beta', so obviously, at this point we expect glitches, bugs, halts in the program, oddities; all of which will be smoothed out as reports come in and that version moves closer to full release.

How'ver, when I downloaded the new beta of Emerald, I didn't get that. In fact, I didn't get anything. I got a black screen. With white words, those words including "Loading..." and the Message of the Day.

Then...plain black screen. No upper bar, no lower bar; no browser, in fact, at all around the perimeter of the unrelieved black screen. Just...black. Just...nothingness.

I logged in once, defaulting to last position; black screen. I logged in a second time, defaulting to home. Black screen. I logged in in other sims; same thing. I went back to Emerald 1.23.

Then a friend of mine contacted the Emerald support group. This is the conversation that followed:

[19:26] Jessica Lyon: ok, hi
[19:26] Jessica Lyon: what is the error your getting?

[19:33] Emilly Orr: With the new beta release, no error. It just won't load. I get words on a black screen, the MOTD, and then that's it
[19:33] Emilly Orr: The words go away, and I'm left with black. It hangs.

[19:34] Jessica Lyon: have you tried logging into a different region?


I know, standard customer service question. I get that. But see, this is why to this day I still have an insane loathing for Frontier Linden--Frontier may have invented the cure for SL cancer, for all I know, in the intervening years...but when friends of mine needed help restarting their sim (back in the days of Live Chat), he asked them thirteen times "Have you cleared cache?" After the first two repetitions of "Yes, I always do that when logging off and logging back in"...then it becomes clear that your customer support is being handled by someone with low banging-rocks-together skills. It's hard for me not to make a snap judgement when the first thing I'm asked is something I try before contacting anyone for help.

[19:40] Emilly Orr: Can't log in. I've tried it set to home, set to last region, and set to a separate sim.
[19:40] Emilly Orr: So I uninstalled and went back to 1.23, which works except for the inventory issue.

[19:41] Jessica Lyon: inventory issue is easy to fix


OMG THANK YOU JESSICA screamed the inside of my head. Really? Emerald has a simple fix for the bane of my existence on Emerald, which I've been talking about for fourteen months solid? Oh, thank the gods, they have BRAINS THAT WORK--

Then she sent me a notecard.

Below, I present to you the text of said notecard:
To Fix inventory and other cache related issues.

1. Make a new folder on your computer where you will remember where it is, and name it Emerald Cache.

2. In Preferences ,, on the Network tab click the set button for "Disk Cache Location" and point to the folder you created,, then hit apply.
3. Relog to a quiet sim and wait for your inventory to reload.
4. to speed up the inventory rebuild process, try typing xxxxxxxxxxxx into your inventory search window.
That is verbatim, spelling errors and all. And all of a sudden I'm back to someone with low banging-rocks-together skills.

Crushing sense of disappointment, people. Crushing.

[19:49] Jessica Lyon: did you get the notecard?
[19:49] Emilly Orr: Well, I can try it again, but that hasn't worked in the past.
[19:50] Emilly Orr: Still, I'll try it again
[19:50] Jessica Lyon: make sure you follow the instructions exactly
[19:50] Jessica Lyon: it fixes it for 100% of our users


Glad she's so confident. But, I did tell her I would do this, so I will do this.

First, I created a new folder in a simple-to-find location and named it "Emerald Cache". I have done this before. This was at four o'clock.

Next, I booted up Emerald, and typed in Glidden, a small low-trafficked university sim. I have done this before. 4:00 to 4:03, to load the program, have it clear, and type in the new destination.

I set up the disc cache line to point to the new location. I was told that, when I relogged, my cache would clear. I have done this before as well. 4:03 to 4:05 to set up the new disc cache location, and log out again.

I quit the program and restarted again, returning to Glidden. I began loading in inventory. Logging in and getting to Glidden took from 4:06 to 4:08 pm; then from 4:08 pm to 4:36, I watched the slow, slow as frozen maple syrup slow, creep of my inventory count upward.

I will say this for their "100% cure" fix: it might have worked for me, save I'd been up since seven this morning and I desperately needed to lay down for a few hours after a physical evaluation (RL). So, when it stopped for the twelfth time, I didn't type in any new search terms to restart it.

This doesn't show things clearly, but it is an actual screen capture shot:

Second Life,Emerald,viewers,virtual worlds. wtf

that shows it stopped on 47,109. Which is, I will grant the Emerald support team and Miss Lyon this--it's far better than my standard 27,000+. And, if I had the six and a half hours it would likely take to load in everything else--I might actually be able to pull in my inventory using this method.

And then have to do it again the next time. And again the next time. And again the next time.

Versus...

Second Life,Emerald,viewers,virtual worlds. wtf

using Snowglobe, where I have my total inventory count--of 72,517--brought onboard in under 90 seconds. Flat. EVERY DAMNED TIME, no matter WHAT sim I'm in.

I think I'm going to state my first case against Emerald: unless I need some specific functionality of that particular viewer, I'm done. I'm on SnowGlobe from here on out.

So we had another quest in Runes of Magic. This is yet again one of those odd, 'Adventurers don't ask a lot of questions" quests; to wit, the retrieval of cursed gold coins from various evildoers around and about the Sailors' Graveyard; a stretch of wreck-littered beachfront haunted by foul beasts and pirate revenants alike.

(Okay, okay, only the pirate ghosts are at the Sailors' Graveyard, the pirate revenants are next to the Throne of Wind...don't get picky.)

We were told to retrieve them from four different places close to the Graveyard, including Shackle Coast and Shadowmoon Cove. After tracking down each new hiding place of the cursed coins, we brought them back to the old man in hiding--who would tell us, each and every time, not to just pour them into his hands, because they were cursed, and the curse would rub off!

At which point we thought the same thing every single time--Well, hell, I've been walking around with these all day, am I cursed now? You could've told us that BEFORE...

But, at any rate, finally, we had them all together, so he carefully bound them into a bag, and handed the bag back to us. "Take these to the Throne of Wind," he said. "Sacrifice them on the stone and pray that this curse does not return for me!"

Yeah, okay, whatever, you're payin' us...so off we went.

Now this quest gets odd. (I know, I know what you're saying--now this quest gets odd? But really. Trust me. Read on.)

Seems a certain teacher named Losi, and her student (named, I am not making this up, Kabuki Tabuki), just happened to be wandering near the Throne of Wind at the time. We took the coins to the center of the cascading winds, alight with powerful, green glowing energies--and threw them into the winds with all our might.

Whereupon, Losi and Kabuki waited until we left, and...gathered them up.

YES REALLY.

We know this because later, Kabuki finds us in the Abandoned Fortress (font of economic enterprise that it is; slated to win the Least Abandoned Fortress award for the 57th year running), and tells us what his teacher and he did. He tells us to go talk to her about it, in fact.

Me, all I could think was, You have a little curse on you there, Kabuki--you might want to get that off...

So...we go talk to her. And she says that they're amazing examples of lost Phant Dynasty coin minting (Runes has a lost Phant dynasty??), and she can't possibly part with them, but if we'd accept these small tokens (a lot of newer gold coins, experience, talent points to spend on abilities, and your usual selection of weaponry and armor) in exchange? She'd be very grateful.

This being the acceptable adventurers' cut for adventuring, we did. And then we noticed someone else we needed to speak to, so we went to talk to him. And that's when the game killed at least seven braincells in me, and quite possibly four in Fawkes (because he didn't see Black Swordsman on the cliff, but he did see the rowdy pirate gang show up to threaten us and then run away like babies.

Unfortunately, I lost more braincells, because of what Black Swordsman was wearing: a thin black thong, black boots, a black cloak, and what looked for all the world like a wrapped black bandeau top.

Seriously. I wish I had pictures, it was that mentally stunning, seeing it.

And then the dialogue between the NPCs began.

[Gunefo Maddis]: What! Oh, not them again...
[Rowdy Sailor]: You dare to violate the sacred ground of the wind? Go to hell!
[Rowdy Vagrant]: You are not welcome here!
[Crooked-mouth Adamon]: Get the hell out of here!
[Black Swordsman]: Black Swordsman is involved in this!
[Crooked-mouth Adamon]: It's Black Swordsman again! How unfortunate. Let's go!
[Rowdy Sailor]: Damn! You won't be so lucky next time!
[Rowdy Vagrant]: Run away! Run away!
[Black Swordsman]: Everyone, you are safe! Goodbye then!


Ah, amateur theatrics at their best. And off he ran. Back to wherever mysterious scantily-clad fantasy superheroes live, one would assume.

I am not making this up. We turned in instruments measuring magical energy in the area; four drunken piratical sots showed up to threaten someone; and the Caped Crossdresser posed on the cliff dramatically to cry foul--thus sending them running for the next hills over.

Maybe they're afraid of the Black Swordsman's Black Thong?

This game is getting more deranged the longer I play it.

2 comments:

Fogwoman Gray said...

You always make me feel better about my piddling little 43K inventory :)
But I am going to have a serious housecleaning of OLD CRAP to see if my performance improves.

Emilly Orr said...

There are at least two performance step-downs that are long established and well known. One is crossing the 20K barrier; it's not so bad, and for most people, is barely noticeable. The other is crossing the 50K barrier, and that one is bad, and highly noticeable.

Of course, this also depends on the speed of your machine, whether it's a quad-core, dual-core, or single core, what else you have running at the time, how high your graphics settings are in world...but just carrying things around in terms of inventory amount does make a difference.